Back to overview
Resolved

Beta Testing

Aug 4, 2026 at 8:46am UTC
Affected services
Tradeaire Live Service

Resolved
Aug 4, 2026 at 8:46am UTC

The tradeaire services are currently in beta testing, and we are regularly deploying updates.

In most cases, these updates will not impact live service, but there may be occasions where users will experience brief interruptions to service.